1. Registration trouble? Please use the "Contact Us" link at the bottom right corner of the page and your issue will be resolved.
    Dismiss Notice

Just Got Myself Into A 6...

Discussion in 'Builds and Fabricators Forum' started by rejeep, Feb 14, 2013.

  1. Jun 27, 2020
    Muzikp

    Muzikp Active Member 2020 Sponsor

    Sacramento Ca.
    Joined:
    Sep 27, 2016
    Messages:
    1,192
    The little pin bent down instead of pointing up (y) Course I've no idea where this thing he is holding goes or what it does :lol:
     
    fhoehle likes this.
  2. Jun 28, 2020
    rejeep

    rejeep Well-Known Member 2020 Sponsor 2019 Sponsor

    Rochester, NY
    Joined:
    Nov 5, 2009
    Messages:
    1,561
    One of the prongs on the chip bent when I was installing...

    there are just so many benefits to EFI on a truck like this... carbs still have their place on the majority of my vehicles.. but the driveability is just night and day when it runs right.
     
    Muzikp and fhoehle like this.
  3. Jun 29, 2020 at 10:16 PM
    rejeep

    rejeep Well-Known Member 2020 Sponsor 2019 Sponsor

    Rochester, NY
    Joined:
    Nov 5, 2009
    Messages:
    1,561
    Well new chip didn’t do it...

    back at it.
     
  4. Jun 29, 2020 at 11:35 PM
    Focker

    Focker That's what I do, I know things and I fix stuff. Staff Member 2019 Sponsor

    Tri-Cities WA
    Joined:
    Aug 18, 2014
    Messages:
    6,646
    :booo:
     
  5. Jun 30, 2020 at 8:00 AM
    Chuck

    Chuck Sponsor

    Southshore Ma
    Joined:
    Sep 19, 2004
    Messages:
    1,393
    Is it still running rich or is the idle high, or both?
    If it’s just the idle and the IAC counts are good on the chip you can manually adjust the TB.
    Do you have a reader?
     
  6. Jun 30, 2020 at 11:05 AM
    rejeep

    rejeep Well-Known Member 2020 Sponsor 2019 Sponsor

    Rochester, NY
    Joined:
    Nov 5, 2009
    Messages:
    1,561
    running rich... driveability is fantastic.. no complaints.. just some exhaust popping from running rich..
    throwing a rich code.

    running richer than the previous chip.. Block Learn number is right at 108 and staying there in closed loop..
    going to call Howell.. but he had suggested adjusting fuel pressure at the throttle body before..
     
  7. Jun 30, 2020 at 11:37 AM
    Ohiowrangler

    Ohiowrangler New Member 2020 Sponsor

    Newark
    Joined:
    May 29, 2019
    Messages:
    40
    could you post a pic of your data list, we could more with numbers. Ron
     
  8. Jun 30, 2020 at 3:31 PM
    rejeep

    rejeep Well-Known Member 2020 Sponsor 2019 Sponsor

    Rochester, NY
    Joined:
    Nov 5, 2009
    Messages:
    1,561
    sure..
    im going to run it through some diagnostic tonight..

    first restricting the fuel pressure a bit to see what changes..

    Mvolt readings on 02 were all over, so its registering and Im going to assume for now its good.
     
  9. Jul 1, 2020 at 9:42 AM
    Chuck

    Chuck Sponsor

    Southshore Ma
    Joined:
    Sep 19, 2004
    Messages:
    1,393
    I would check the return psi before restricting fuel pressure, return should be zero. If you find 2 psi or above you have a return restriction this would cause the engine to run rich. What is your feed psi?
     
  10. Jul 1, 2020 at 9:59 AM
    rejeep

    rejeep Well-Known Member 2020 Sponsor 2019 Sponsor

    Rochester, NY
    Joined:
    Nov 5, 2009
    Messages:
    1,561
    I have a perm gauge on the feed.. running 12 psi
    looking for another gauge to put on return to check what you are saying..

    restricting the inlet pressure to ~10 psi got me to the correct Block learn number at idle
    but any throttle and it would stumble..

    no anomalous RPM signal.. watched that for a while last night

    sprayed motor down with carb cleaner and no RPM change so I'm assuming no vacuum leaks
     
  11. Jul 1, 2020 at 11:56 AM
    Ohiowrangler

    Ohiowrangler New Member 2020 Sponsor

    Newark
    Joined:
    May 29, 2019
    Messages:
    40
    coolant temp sensor?
     
  12. Jul 1, 2020 at 1:01 PM
    Chuck

    Chuck Sponsor

    Southshore Ma
    Joined:
    Sep 19, 2004
    Messages:
    1,393
    Feed is spot-on at 12 psi. Restricting the feed line doesn’t tell you much especially if you know your feed psi. I’m interested in hearing the return results. Howell tunes the 6 cylinders well but not so much with V8s.

    I once got a super deal on a CJ with a V8 because the two previous owners couldn’t get it to run correctly. It had a Howell (GM) setup and halfway through my diagnostics I determined it was the tune (chip). Howell disagreed, said it had to be something else because their records showed it was tuned correctly. So I did a complete inspection testing every sensor and each wire running from the ecm to the sensors plus all grounds, including swapping out the ecm to a good known used one I had. Gave the results to Howell and they said, “well, I guess it’s the chip. They sent me a fresh tune and the engine ran fantastic.
     

Share This Page

New Posts